Page 3 of 3

Re: 425 Can't Open Data Connection

Posted: 2017-02-24 05:35
by mossy
Oh boy, boco is right, I ran thru the entire thread just to realize.... Don't use Windows FTP.exe. Most modern servers setup with mild security will block it's outdated methods.

Thanks guys.


Re: 425 Can't Open Data Connection

Posted: 2017-05-22 20:34
by taz1004
Something is wacky. I just replaced my FTP server and copied the setting exactly and started getting this error. And I checked that everything on this thread and I was still getting the error. So I decided to turn off FTP over TLS by checking off Enable FTP over TLS support. And checked off Use custom port range in Passive mode settings. And External Server IP to Default. And it worked.
And then just to see which setting was causing the issue, I turned them back on one by one. First the FTP over TLS. It worked. Next, checked on Use custom port range. It worked again. Set external IP address back to what it was. Still working. So in the end, I just went back to how it was when it wasn't working. And now it works.

Don't understand this at all but just posting here as something else to try for those still having issue.

EDIT: Never mind, it stopped working again. Changing settings don't take effect immediately? It is definitely FTP over TLS causing this issue for me. I set everything that is suggested here. Maybe it's Windows 10 creators update?

Re: 425 Can't Open Data Connection

Posted: 2017-05-23 08:43
by botg
If it works without FTP over TLS but fails with it enabled you have a malicious firewall or NAT router tampering with the connection.

Re: 425 Can't Open Data Connection

Posted: 2017-05-23 08:44
by noelsantoro
I've my FTP server on VM and I use pfsense firewall.

I can connect on my LAN Network but I can't outside.

I've tested with , and this is teh result :

Command: PBSZ 0
Reply: 200 PBSZ=0
Command: PROT P
Reply: 200 Protection level set to P
Command: PWD
Reply: 257 "/" is current directory.
Status: Current path is /
Command: TYPE I
Reply: 200 Type set to I
Command: PASV
Reply: 227 Entering Passive Mode (79,7,120,125,197,84)
Command: MLSD
Reply: 425 Can't open data connection for transfer of "/"
Error: Listing failed

so,.. I've set the passive port to 50000/51000
and 256*197+84 = 50516

I've set into firewall Rules and NAT :

WAN server adress 21 (FTP) FTP Service
WAN server adress 50000 - 51000 FTP Passive Mode
IPv4 TCP server adress 21 (FTP)
IPv4 TCP server adress 50000 - 51000

and also into Router Gateway I've set the Port Mapping TCP port 21

Any help , please ..

Re: 425 Can't Open Data Connection

Posted: 2017-05-23 09:28
by botg
What about the mapping for ports 50000 through 51000 in the gateway router?

Re: 425 Can't Open Data Connection

Posted: 2017-05-23 09:50
by noelsantoro
I've tryed to mapping the port 50000/51000 on the Router Gateway setting ..
without change..

Re: 425 Can't Open Data Connection

Posted: 2018-05-16 17:05
by ElfoRojo
Hi all, am having this error trough a VPN Connection whit NAT, if i connect from the public IP (static) work fine, if i connect from internal IP works fine,
but when the people try to connect from a VPN whit NAT get the error 425 Can't Open Data Connection

the passive ports are open on both firewalls , the connection trough the 2222 port FTPS works but cant retrive the directories.

what can we do to solve this!

Re: 425 Can't Open Data Connection

Posted: 2018-11-16 18:11
by Tariq3Khan
I have found this to work =

Allow 50025 - 50050 - on your router. Forward to the FTP Server

From within the FTP Server Application - Under Passive Setting, allow these same ports.

This is not from me. I got this from an earlier poster in this same thread. It worked.

Tariq Khan

Re: 425 Can't Open Data Connection

Posted: 2019-02-13 22:21
by somebody08
The solution for me, was that my IP address had changed, and I didn't update it under

Settings > Passive mode settings

Use the following IP address: XXX.XXX.XXX.XXX

Re: 425 Can't Open Data Connection

Posted: 2019-02-14 06:42
by boco
You can use the Retrieve option to have it updated automatically. Or, you can enter a DNS/Hostname into the IP field to have the IP resolved.