FileZilla Forums

Welcome to the official discussion forums for FileZilla
Donate to project
It is currently 2014-07-14 10:40

All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 2007-06-21 04:46 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
I can access my Filezilla server behind my router and comodo firewall...in other words I have all the ports mapped through properly I think. I can transfer files and they arrive at the server. However, I always get an "empty directory listing" on the remote (server) side, and when I transfer a file, it will show up in the remote directory listing until I transfer another, then it disappears. When I am at the remote server in person, all of the files are there, the subdirectories are there. They just never show up when I log in from work using the client.

Any suggestions?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-21 06:30 
Offline
226 Transfer OK

Joined: 2006-04-27 08:48
Posts: 242
Location: Arizona, USA
http://filezilla.sourceforge.net/forum/ ... php?t=3837

_________________
Microsoft MVP (2004 through 2008)


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-21 15:21 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
thank you for your attempt at helping. I have read through that link several times already, and am not sure my situation is the same.
I am not getting the 425 error. I can execute commands, transfer files, etc all successfully. I can transfer multiples files. It doesn't stop working after the first command. The list command executes as often as I wish, it just doesn't show any files on the remote.
My ports are forwarded through the router and the software firewall (20-21 and 5100-5150).

My router is a Belkin F5D7230-4. Could it be susceptible to that "PASV converted to P@SW" bug? What are the symptoms?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-21 15:36 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22987
If you enable "Show raw directory listings" on the debug page in the settings dialog, do the files appear in the message log? If so, please post the contents of the message log.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-21 16:40 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
Is this what you mean by "message log" ? I did enable "Show raw directory listings".


Response: 230 Logged on
Command: SYST
Response: 215 UNIX emulated by FileZilla
Command: FEAT
Response: 211-Features:
Response: MDTM
Response: REST STREAM
Response: SIZE
Response: MODE Z
Response: MLST type*;size*;modify*;
Response: MLSD
Response: UTF8
Response: CLNT
Response: MFMT
Response: 211 End
Status: Connected
Status: Starting upload of C:\OldDrive\WAV\JOEY.WAV
Command: PWD
Response: 257 "/" is current directory.
Command: TYPE I
Response: 200 Type set to I
Command: MODE Z
Response: 200 MODE set to Z.
Command: OPTS MODE Z LEVEL 8
Response: 200 MODE Z LEVEL set to 8
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,19,251)
Command: STOR JOEY.WAV
Response: 150 Connection accepted
Response: 226 Transfer OK, compression saved 15948 of 64700 bytes (24.65%)
Status: Upload successful
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Command: MODE Z
Response: 200 MODE set to Z.
Command: OPTS MODE Z LEVEL 8
Response: 200 MODE Z LEVEL set to 8
Command: TYPE A
Response: 200 Type set to A
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,19,252)
Command: LIST
Response: 150 Connection accepted
Trace: <Empty directory listing>
Response: 226 Transfer OK, compression saved 522 of 808 bytes (64.61%)
Status: Directory listing successful
Command: REST 0
Response: 350 Rest supported. Restarting at 0
Command: REST 0
Response: 350 Rest supported. Restarting at 0


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 16:13 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22987
What happens if you disable compression? Also, what server version?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 20:27 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
server version is 0.9.23 beta

I have tried both with and without compression. same result. server is running on Windows XP Home SP2.

I created a new user, made a different directory (that contains files) the home and I get the same thing. I don't know what the 503 error means.

Response: 230 Logged on
Command: SYST
Response: 215 UNIX emulated by FileZilla
Command: FEAT
Response: 211-Features:
Response: MDTM
Response: REST STREAM
Response: SIZE
Response: MLST type*;size*;modify*;
Response: MLSD
Response: UTF8
Response: CLNT
Response: MFMT
Response: 211 End
Status: Connected
Status: Starting upload of C:\OldDrive\WAV\BUELLER1.WAV
Command: PWD
Response: 257 "/" is current directory.
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,20,8)
Command: STOR BUELLER1.WAV
Response: 150 Connection accepted
Response: 226 Transfer OK
Status: Upload successful
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Command: TYPE A
Response: 200 Type set to A
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,20,9)
Command: LIST
Response: 150 Connection accepted
Response: 226 Transfer OK
Trace: <Empty directory listing>
Status: Directory listing successful
Command: TYPE A
Response: 200 Type set to A
Command: PWD
Response: 257 "/" is current directory.
Status: Starting upload of C:\OldDrive\WAV\CHICKEN.WAV
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,20,10)
Command: STOR CHICKEN.WAV
Response: 150 Connection accepted
Response: 226 Transfer OK
Status: Upload successful
Status: Retrieving directory listing...
Command: TYPE A
Response: 200 Type set to A
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,20,11)
Command: LIST
Response: 150 Connection accepted
Trace: <Empty directory listing>
Response: 226 Transfer OK
Status: Directory listing successful
Command: LIST
Response: 503 Bad sequence of commands.
Status: Retrieving directory listing...
Command: TYPE A
Response: 200 Type set to A
Command: PASV
Response: 227 Entering Passive Mode (70,231,236,103,20,12)
Command: LIST
Response: 150 Connection accepted
Trace: <Empty directory listing>
Response: 226 Transfer OK
Status: Directory listing successful
Command: REST 0
Response: 350 Rest supported. Restarting at 0
Status: Disconnected from server


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 21:11 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22987
Do other clients work?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 21:26 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
They all connect, I can transfer, etc. but still get empty directory listing no matter what. Cute FTP and Core FTP Lite give the same results.

I am baffled.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 21:31 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22987
Are the directories shared by FileZilla Server by any chance mapped network drives or network shares?


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 21:38 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
I have tried several. They are not mapped drives. They mostly reside on the C:\ drive and are not shared. I also have tried an external USB hardrive set up as drive F:/. No joy.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-22 21:58 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
By the way, I have CORE SFTP server running on port 22, it works fine and I can see all the directory listings.

I would like to use Filezilla though. I appreciate your help.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-23 08:24 
Offline
Site Admin
User avatar

Joined: 2004-02-23 20:49
Posts: 22987
Unfortunately I'm out of ideas.


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-24 18:56 
Offline
226 Transfer OK

Joined: 2006-04-27 08:48
Posts: 242
Location: Arizona, USA
So... How does it function when the router is not involved (e.g. local LAN functionality)?

_________________
Microsoft MVP (2004 through 2008)


Top
 Profile  
 
 Post subject:
PostPosted: 2007-06-24 19:49 
Offline
504 Command not implemented

Joined: 2007-06-21 04:40
Posts: 9
that will be my next test. I suspect the router is the culprit. I will try it in the dmz and then swap out routers when I can.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Dedicated server provided by Artmotion.
Forum sponsored by Everyware.ch.
Powered by phpBB® Forum Software © phpBB Group