227 Entering Passive Mode (199,168,79,56,19,138)

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

227 Entering Passive Mode (199,168,79,56,19,138)

#1 Post by johhnyk » 2018-10-16 16:34

This driving me nuts. I just got Metronet FIOS, configured filezilla latest server. Disabled windows10 firewall. Disabled comodo free firewall. Disabled router firewall.

This 227 Entering Passive Mode (199,168,79,56,19,138) is stuck trying to login through ftp client from external IP.

johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#2 Post by johhnyk » 2018-10-16 16:50

https://ftptest.net says
Make sure the account has permissions to list directories.

I have all available check boxes checked under my username of the server profiles.

User avatar
boco
Contributor
Posts: 24156
Joined: 2006-05-01 03:28
Location: Germany

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#3 Post by boco » 2018-10-16 17:10

Did you forward all ports (including data port range) through the router? Network Configuration
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#4 Post by johhnyk » 2018-10-16 17:21

boco wrote:
2018-10-16 17:10
Did you forward all ports (including data port range) through the router? Network Configuration
This?
Image

User avatar
boco
Contributor
Posts: 24156
Joined: 2006-05-01 03:28
Location: Germany

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#5 Post by boco » 2018-10-16 17:30

These are only the listening port forward rule (21 for Plain FTP and Explicit FTP over TLS), and the one for Implicit FTP over TLS (990). Where's the rule for the data port range? The Custom port range you defined in the Passive settings of the FTP server, it needs to be forwarded and opened as well.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#6 Post by johhnyk » 2018-10-16 17:45

Isn't routers suppose to have port to port forwarding?

Under passive I have port set 60000 to 61000, on the router firewall, I don't see a port to port, port forwarding option.

(000043)10/16/2018 13:42:25 PM - johnny (136.243.154.86)> 227 Entering Passive Mode (199,168,79,56,236,146)
(000043)10/16/2018 13:42:25 PM - johnny (136.243.154.86)> MLSD
(000043)10/16/2018 13:42:36 PM - johnny (136.243.154.86)> 425 Can't open data connection for transfer of "/"
(000043)10/16/2018 13:42:36 PM - johnny (136.243.154.86)> disconnected.

Image

johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#7 Post by johhnyk » 2018-10-16 21:46

Is this the data ports you're talking about? 60000-61000? i cant find nothing on data ports on the wiki.

Image

johhnyk
504 Command not implemented
Posts: 6
Joined: 2018-10-16 16:30
First name: John
Last name: Kurzeja

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#8 Post by johhnyk » 2018-10-16 22:57

I got in! wow.

Ok as stated on the wiki, I changed passive ports 50000 to 50000. Port forwarded that 50000 in NAT of the router. Disabled "Require TLC session resumption on data connection...". And bam, I am connected.

User avatar
boco
Contributor
Posts: 24156
Joined: 2006-05-01 03:28
Location: Germany

Re: 227 Entering Passive Mode (199,168,79,56,19,138)

#9 Post by boco » 2018-10-17 00:25

I'm pretty sure the Wiki example pic says 50000 to 51000 (it should just be in the high region >49151 as those ports are unused). The text tells you to use min. 50 ports. One data port is not enough. and what your router shows on the site is just rules for single ports. The 60000 to 61000 rule is plain wrong.

You need to add a range, e. g. best use Service Name "Custom" and try to enter a range (50000-50100) and the same range (or the first port of it,depending on router) as local (translation) port. Then, add the same range as Custom port range in FZ Server.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Post Reply