FTP Server port 21 over Google Fiber

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
500 Command not understood
Posts: 1
Joined: 2018-11-06 16:55
First name: Stefan
Last name: Zauchenberger

FTP Server port 21 over Google Fiber

#1 Post by stefanz » 2018-11-06 17:03

Hi all,

Have a smaller client that has been using a Cyberoam CR15ing for quite a with a Google Fiber connection and a LAN of about 15 endpoints. They recently moved, but the ISP is still Google Fiber. They had to leave the GF box, but we configured the new one identical to the original. So the only difference should be the public / external IP of the GF box - which is set with the CR15ing as the "DMZ" (all traffic passed through to this device). This is bridge-mode setting for the GF box, but the Cyberoam still gets an internal IP on its WAN side. Not sure any of this matters, as the exact same config worked for years at the previous location with same ISP, same hardware, act.

The Google Fiber network box does not have the ability to do full bridged or pass-through mode. NAT cannot be disabled. Instead they have this thing call DMZ mode, where you pass all public traffic to designated internal IP. The WAN side of the Cyberoam is set to this IP. See here - https://support.google.com/fiber/answer/4650342?hl=en

Created a RDP port forward over 3389 to one of the internal machines - and that worked fine.

The FTP port forward is still failing. I can connect to the FTP server internally by the LAN IP, but forwarding 21/TCP from the external IP is not taking me there.

If I change the Filezilla server to port 2121 and forward that, it works. Not sure why there would be a problem with port 21.

Unfortunately, the client has a predefined piece of software that depends on port 21.

Please let me know if you have any ideas / suggestions.


User avatar
Site Admin
Posts: 33054
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse

Re: FTP Server port 21 over Google Fiber

#2 Post by botg » 2018-11-06 21:30

Why have they produced a shitty box that can't even be put into bridge mode? That's a question for Google.

Post Reply