Passive Connection issue on Server

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
richardj72
500 Command not understood
Posts: 1
Joined: 2019-01-23 09:37
First name: Richard
Last name: Johnston

Passive Connection issue on Server

#1 Post by richardj72 » 2019-01-23 10:27

HI All

I am running FileZillea Server configured with the Passive connection.

The server has the Fixed public address configured in settings and is currently allowing a Set amount of Dynamic ports for each client.

This works well but our servers, in the same local IP address network as the FTP Server, cannot make the complete connection to the server.

Even with the "Don't use External IP for local connections" option enabled, the local servers still make the Passive connection with the External/Public address.

Transfers don't work and the Firewall sees this as a SYN Attack.

The connection Authenticates fine but the moment it hands over to passive, the Public IP Address is returned and we cannot retrieve the Shared directory


Is there any way of getting around this apart from maybe creating a 2nd Instance and using the Local IP address as the server ?

Please let me know, thank you. :D

User avatar
botg
Site Admin
Posts: 32280
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Passive Connection issue on Server

#2 Post by botg » 2019-01-23 11:12

Transfers don't work and the Firewall sees this as a SYN Attack.
Sounds like the firewall is the source of your problems. Try removing it.

Post Reply