Slow upload speed

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
James_liv
500 Syntax error
Posts: 17
Joined: 2019-04-01 17:08
First name: James
Last name: Livingstone

Slow upload speed

#1 Post by James_liv » 2019-04-01 17:20

Evenin'

I've set up a server a few months ago to stream video files to various android devices around the house.

These all work fine but I can't seem to stream UHD files quick enough to play them.

I'm running it on an internal network, all hardwired via ethernet and so I can't figure out why it won't stream the video files fast enough.

It's tra sering the data at around 3mbps.

Nb. I also have a family member who downloads from the FTP but clearly this isn't an issue for them as they are downloading.

User avatar
boco
Contributor
Posts: 25386
Joined: 2006-05-01 03:28
Location: Germany

Re: Slow upload speed

#2 Post by boco » 2019-04-01 22:50

3Mbps (megabits/sec) would be 375KBps. That's not enough for any streaming. You mean 3MBps (MegaByte/sec), right. Is that a constant limit of exactly that speed?

That's very slow. Is this wired or WiFi? Provided you didn't set any speed limits in FZ Server, check for any overzealous security software or any kind of traffic shaping.

Also, try playing with the buffer sizes in the settings. Double or quadruple them (always use multiples) and see if it helps.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

James_liv
500 Syntax error
Posts: 17
Joined: 2019-04-01 17:08
First name: James
Last name: Livingstone

Re: Slow upload speed

#3 Post by James_liv » 2019-04-02 08:40

Yeah, sorry.

No it's not constant. It jumps around quiet a bit.
Anywhere from 500kbps to 3.5MBps.

If it's a 1080p or below video then it plays but uhd it doesn't.

Even getting a directory listing can take a good few minutes the first couple of times.

It's in passive mode.

The internal transfer buffer size is 4 x the default (131072) and the socket buffer size is 1048576.

It seems to take a few attempts to play anything. I get a lot of 'could not send reply. Disconnected'
But anything below 1080p - even large 30gb files - play fine, however anything in 4k stays between 200kbps and 450kbps - even thou my test file is only around 18gb.

Thanks in advance

User avatar
botg
Site Admin
Posts: 33309
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Slow upload speed

#4 Post by botg » 2019-04-02 09:21

Even getting a directory listing can take a good few minutes the first couple of times.
This should be instant. What does it say in the message log when it takes time?

James_liv
500 Syntax error
Posts: 17
Joined: 2019-04-01 17:08
First name: James
Last name: Livingstone

Re: Slow upload speed

#5 Post by James_liv » 2019-04-02 09:51

Just tried to again now and in fairness it's a bit hit and miss and some directories are only a second or so.
Another time I counted 23 seconds.

It says,

PASV
Entering passive mode
TYPE A
Type set to A
LIST

*****this is where it seems to pause for a while*****

Opening channel for directory listing
Successfully transfered

The streaming speed on UHD files is still 250kbps regardless of the directory list speed.

User avatar
botg
Site Admin
Posts: 33309
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Slow upload speed

#6 Post by botg » 2019-04-02 17:31

Could you please post a complete and unmodified log from FileZilla Server?

Post Reply