Can't enable passive mode

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Lenator
500 Command not understood
Posts: 2
Joined: 2019-07-03 08:49
First name: Lenator
Last name: Hahator

Can't enable passive mode

#1 Post by Lenator » 2019-07-03 13:34

I was trying to set up an FTP Server with Filezilla Server, but when I was trying to connect to the server I got this:
(000015)03.07.2019 16:39:50 - (not logged in) (178.127.67.219)> Connected on port 21, sending welcome message...
(000015)03.07.2019 16:39:50 - (not logged in) (178.127.67.219)> 220 Кхм...
(000015)03.07.2019 16:39:50 - (not logged in) (178.127.67.219)> USER root
(000015)03.07.2019 16:39:50 - (not logged in) (178.127.67.219)> 331 Password required for root
(000015)03.07.2019 16:39:50 - (not logged in) (178.127.67.219)> PASS ******************
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 230 Logged on
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> SYST
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 215 UNIX emulated by FileZilla
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> PWD
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 257 "/" is current directory.
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> TYPE I
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 200 Type set to I
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> SIZE /
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 550 File not found
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> CWD /
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 250 CWD successful. "/" is current directory.
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> PASV
(000015)03.07.2019 16:39:50 - root (178.127.67.219)> 227 Entering Passive Mode (178,127,67,219,215,9)
(000015)03.07.2019 16:39:51 - root (178.127.67.219)> QUIT
(000015)03.07.2019 16:39:51 - root (178.127.67.219)> 221 Goodbye
(000015)03.07.2019 16:39:51 - root (178.127.67.219)> disconnected.
So the passive mode can't enable with command PASV.
Help me, please.
------Sorry for my English------

User avatar
botg
Site Admin
Posts: 32432
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Can't enable passive mode

#2 Post by botg » 2019-07-03 14:54

What does it say in the client log?

Lenator
500 Command not understood
Posts: 2
Joined: 2019-07-03 08:49
First name: Lenator
Last name: Hahator

Re: Can't enable passive mode

#3 Post by Lenator » 2019-07-03 18:26

Connecting with 178.127.67.219:21 ...
Status: Connection established, waiting for invitation ...
Status: Insecure server, does not support FTP over TLS.
Status: Authorized
Status: Getting a list of directories ...
Team: PWD
Answer: 257 "/" is current directory.
Team: TYPE I
Answer: 200 Type set to I
Team: PASV
Answer: 227 Entering Passive Mode (178,127,67,219,228,224)
Team: MLSD
Error: Data connection cannot be established: ECONNREFUSED - Connection rejected by server
Answer: 425 Can't open data connection for transfer of "/"

User avatar
boco
Contributor
Posts: 24758
Joined: 2006-05-01 03:28
Location: Germany

Re: Can't enable passive mode

#4 Post by boco » 2019-07-03 19:53

Both client and server log must be from the same session. Yours either aren't, or something evil is going on. The commands/responses are not matching up. Additionally, FileZilla does not send the QUIT command, ever.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

User avatar
botg
Site Admin
Posts: 32432
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Can't enable passive mode

#5 Post by botg » 2019-07-04 08:03

Yup, definitely a malicious firewall sabotaging the data.

Post Reply