Client login shows only folders named 'data' and 'fw'

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
mb21uk
500 Command not understood
Posts: 1
Joined: 2020-04-08 10:09
First name: Mike
Last name: Brown

Client login shows only folders named 'data' and 'fw'

#1 Post by mb21uk » 2020-04-08 10:33

I have installed Filezilla server on a PC running Windows 10 behind a Zyxel router. I have created port forwarding rules in the router for ports 21.22 and 5000-5100.

When the server starts up the log shows this message:

Connecting to server localhost:14147...
Connected, waiting for authentication
Logged on
Warning: FTP over TLS is not enabled, users cannot securely log in.

I have set up a user, a group, set folder accesses for the group and joined the user to the group

When a remote client connects it authenticates but only gives access to folders named 'data' and 'fw'

Anyone know what might be causing this and what I need to do to get access to the folders I have specified?

Thanks.

User avatar
boco
Contributor
Posts: 25185
Joined: 2006-05-01 03:28
Location: Germany

Re: Client login shows only folders named 'data' and 'fw'

#2 Post by boco » 2020-04-08 10:53

I have created port forwarding rules in the router for ports 21.22 and 5000-5100.
Port 22 is for SFTP, FileZilla Server does not support SFTP. Not required.
When a remote client connects it authenticates but only gives access to folders named 'data' and 'fw'
Your router has an internal FTP server enabled, meant for remote maintenance. Not only does it override your server machine's FTP, but it is a dangerous security vulnerability. Disable remote access and the internal FTP server of the router.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Post Reply