Page 1 of 1

Server doesn't work behind a router

Posted: 2020-05-05 22:35
by vittorio7
Hello everyone!

A couple of years ago I have used FileZilla Server and it worked. But now I moved to a new flat and changed my ISP.
They gave me a router with only few capabilities, the Connect Box (probably by Cisco), and now I can't make the server work.

See Screenshots for details...

I have tested my settings on
Results are below...

Code: Select all

Test log
Warning: Allowing fallback to plaintext FTP is insecure. You should use explicit FTP over TLS.
Status: Resolving address of ***
Status: Connecting to ***
Error: Connection attempt timed out

Error: Connection attempt timed out
Timeouts are usually caused by some router and/or firewall that is interrupting the connection.
Try uninstalling all firewalls and plug your computer directly into your modem, thus bypassing the router.

I am using ESET Internet Security as Software Firewall and it is set up to "interactive mode", that means a window pops out for every attempted in- or outbound connection, which I then have to accept or not.
The router firewall is disabled.

Now, I tried anything I knew with no success. Any ideas? Maybe I missed something? Any help appreciated.

P.S.: I changed Passive Mode Settings > use custom port range > 50000 - 51000

Re: Server doesn't work behind a router

Posted: 2020-05-06 08:12
by botg
FTP only uses TCP, not UDP.

Outbound you need to allow all traffic without restriction.

Inbound you need to also allow the configured passive mode port range, or everything if no range configured. Only the destination port is under your control, the source port can be anything.

Re: Server doesn't work behind a router

Posted: 2020-05-06 11:23
by boco
As I just see the "IPv6" in the router configuration: Does you ISP provide you with a real, valid IPv4 (i. e. DualStack) address? If not (like with DSLite configuration), you can expect problems, especially with non-IPv6 capable clients.