425 Can't open data connection for transfer of "/"

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
XaaL
500 Command not understood
Posts: 1
Joined: 2020-08-02 18:46

425 Can't open data connection for transfer of "/"

#1 Post by XaaL » 2020-08-02 19:11

Hello!

Before you burn this thread to ashes and bury it to the ground, let me start with: i've read all on this topic i could find. I know this has been asked multiple times, on various platforms. YET none of suggested solutions did the trick for me.

I'm trying to run two filezilla servers at the same time (different machines, different subnets, common gateway).

The first one works somewhat ok-ish (in the logs i'm getting the router ip, instead of actual client- didn't look into that yet). The other one worked twice- in my opinion- at random.

Here's the deal: i have 4 public ip's from my isp. One of them (let's call it 1.1.1.1) is used for the first fzs (let's call it 10.10.1.1). The other one (1.1.1.2) was designated to operate the other fzs (10.10.2.2).

So when i'm trying to connect from another network (3.3.3.3 -> 1.1.1.1:21) i'm being properly connected to 10.10.1.1 fzs. However when i'm trying to do the same with another one (3.3.3.3 -> 1.1.1.2:21) i'm being connected to 10.10.2.2, but getting the error from the title.

And now is the tricky part- IT USED TO WORK maybe twice, but in most cases i'm getting the 425 error. If it were consistent- it would be easier to track down. I spent whole day on this and no luck. I'm tired, out of ideas and sad:(

Any insight is welcomed.

Also: I'm using mikrotik CCR as my main router, i believe all my forwards are set properly, my system firewall is off at this point (on 10.10.2.2).
Using win10pro x64, fzs: 0.9.60 beta, passive mode, followed https://wiki.filezilla-project.org/Netw ... figuration thrice.

Help?

User avatar
botg
Site Admin
Posts: 33125
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: 425 Can't open data connection for transfer of "/"

#2 Post by botg » 2020-08-03 07:15

The first one works somewhat ok-ish (in the logs i'm getting the router ip, instead of actual client- didn't look into that yet)
What is the actual client IP in this scenario?

If you want to connect from within your NATted local network to a server inside the same local network, you need to connect through the server's private IP address.

Considering you have multiple public IP addresses, consider not using NAT at all.

Post Reply