Strange 425 Can't open data connection for transfer of "/" when using IE or FileZilla but TC works

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
projektilski
500 Command not understood
Posts: 2
Joined: 2020-11-03 09:30
First name: Petar
Last name: Samardzija

Strange 425 Can't open data connection for transfer of "/" when using IE or FileZilla but TC works

#1 Post by projektilski » 2020-11-03 10:17

Hi all,
I have a strange problem. I can list folder from my FTP server with only Total Commanders built in FTP client. I can't list via browser of FileZilla client on the same PCs (multiple PCs on different networks).
I have opened ftp port 21 and custom port range for passive transfer (52000-53000) in my router and everything seems setup correctly. With Total Commander I can get to list folders in active and passive mode but not with other clients.

I tried to troubleshoot it my self so I compared logs when connecting via FileZilla client and via Total Commander and it seems that Total Commander uses TYPE A as transfer mode and other clients TYPE I. But I don't know why and if that is the problem and why

FileZilla:
Image

Total Commander:
Image

User avatar
botg
Site Admin
Posts: 33239
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Strange 425 Can't open data connection for transfer of "/" when using IE or FileZilla but TC works

#2 Post by botg » 2020-11-03 13:35

Total Commander is insecure, it does not use FTP over TLS by default.

Please refer to our Network Configuration guide for correct firewall and NAT router configuration. You can test your server on https://ftptest.net/

projektilski
500 Command not understood
Posts: 2
Joined: 2020-11-03 09:30
First name: Petar
Last name: Samardzija

Re: Strange 425 Can't open data connection for transfer of "/" when using IE or FileZilla but TC works

#3 Post by projektilski » 2020-11-03 22:30

I tried to enable FTP over TLS in TC and it worked also. I also tried to disable FTP over TLS in FileZilla Server to see if FileZilla Client would connect but it would not.
I still don't understand why TC works and other programs don't.
Does this Type A vs Type I have anything to do with it? Why is that different in TC & FileZilla?

I did check Network Configuration page but it did not help.

User avatar
boco
Contributor
Posts: 25332
Joined: 2006-05-01 03:28
Location: Germany

Re: Strange 425 Can't open data connection for transfer of "/" when using IE or FileZilla but TC works

#4 Post by boco » 2020-11-04 00:09

If you check the logs, TC uses Active mode (PORT) and FileZilla uses Passive (PASV) mode by default. The server seems to be configured wrong (or butchered by a firewall) and Passive mode fails. For some reason, Active mode seems to work, and FileZilla should too if switched to Active.

The TYPE command is unrelated, it only sets Data Type.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

Post Reply