Page 1 of 1

Ftps config error

Posted: 2021-02-01 13:14
by KingWong0801
Dear Sir,

I have configed the ftps correct, but the interface warm me some error :

FileZilla Server 0.9.60 beta
Copyright 2001-2016 by Tim Kosse (tim.kosse@filezilla-project.org)
https://filezilla-project.org/
Connecting to server localhost:14147...
Connected, waiting for authentication
Logged on
You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.
Could not load certificate file: error:02001003:system library:fopen:No such process (0)
Retrieving account settings, please wait...
Done retrieving account settings
Retrieving account settings, please wait...
Done retrieving account settings
Retrieving settings, please wait...
Done retrieving settings
Sending settings, please wait...
Done sending settings.
Could not load certificate file: error:02001003:system library:fopen:No such process (0)
You appear to be behind a NAT router. Please configure the passive mode settings and forward a range of ports in your router.

I Use the Windows Server 2019, and Installed the Filezilla Server with Administrator account.

I gerneral the key by filezilla server application with 1024bite.

I have set the key the permision to everyone could access.

Please give me a help, thanks!

Re: Ftps config error

Posted: 2021-02-01 13:17
by KingWong0801
this is my applicate shot
QQ截图20210201210925.jpg
QQ截图20210201210925.jpg (21.29 KiB) Viewed 665 times
QQ截图20210201210835.jpg
QQ截图20210201210835.jpg (47.58 KiB) Viewed 665 times
QQ截图20210201210715.jpg
QQ截图20210201210715.jpg (60.15 KiB) Viewed 665 times

Re: Ftps config error

Posted: 2021-02-01 15:05
by botg
Try using a path for the certificate and key file that only contains English characters.

Re: Ftps config error

Posted: 2021-02-02 05:14
by KingWong0801
botg wrote:
2021-02-01 15:05
Try using a path for the certificate and key file that only contains English characters.
Thanks,I set it to english path and it works correctly.
So it proved that the setting is not compatable with chinese.

Re: Ftps config error

Posted: 2021-02-02 07:28
by boco
Most probably the legacy OpenSSL version used is not completely Unicode-compatible.