FileZilla won't use my system default date format

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Louter
504 Command not implemented
Posts: 9
Joined: 2015-10-04 11:30

FileZilla won't use my system default date format

#1 Post by Louter » 2015-10-04 11:44

I'm using Windows 10 and FileZilla 3.14.0 64-bit. My system date is set to English dd/mm/yyyy format and I've got Settings -> date/time format set to "use system defaults". Despite this, FileZilla displays my dates in American mm/dd/yyyy format. How can I get my date format corrected?

User avatar
boco
Contributor
Posts: 25241
Joined: 2006-05-01 03:28
Location: Germany

Re: FileZilla won't use my system default date format

#2 Post by boco » 2015-10-04 14:43

Is the basic system en-US? If yes, and if you installed FileZilla for All Users, it might use the System Regional settings instead of your user account settings. In Region settings (Admin tab), you can copy your settings to All Users and Default User accounts, that should make FileZilla honor them (after a reboot).
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

User avatar
botg
Site Admin
Posts: 33119
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FileZilla won't use my system default date format

#3 Post by botg » 2015-10-04 14:46

Sounds like the irreproducible https://trac.filezilla-project.org/ticket/9675

User avatar
botg
Site Admin
Posts: 33119
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FileZilla won't use my system default date format

#4 Post by botg » 2015-10-04 14:47

boco wrote:Is the basic system en-US? If yes, and if you installed FileZilla for All Users, it might use the System Regional settings instead of your user account settings.
Only if manually starting FZ with Windows' guest account.

Louter
504 Command not implemented
Posts: 9
Joined: 2015-10-04 11:30

Re: FileZilla won't use my system default date format

#5 Post by Louter » 2015-10-04 16:00

botg wrote:Sounds like the irreproducible https://trac.filezilla-project.org/ticket/9675
It looks and sounds like that problem. I presume it's a bug in FileZilla since my system is clearly set to English UK and all other software respects my correct date format. I haven't encountered this bug with previous versions of FileZilla.

toastpod
500 Command not understood
Posts: 4
Joined: 2016-03-03 17:13

Re: FileZilla won't use my system default date format

#6 Post by toastpod » 2016-03-03 17:39

This issue continues to affect me too.

I just wondered, have the people attempting to reproduce this bug changed the Windows region format settings as attached before testing?
Attachments
time.png
time.png (13.05 KiB) Viewed 3199 times

User avatar
boco
Contributor
Posts: 25241
Joined: 2006-05-01 03:28
Location: Germany

Re: FileZilla won't use my system default date format

#7 Post by boco » 2016-03-04 04:37

If you change to the Administrative tab, there should be a button to copy all region settings to the Default User and System accounts. After doing that (and having rebooted), does FileZilla use the correct settings?
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

toastpod
500 Command not understood
Posts: 4
Joined: 2016-03-03 17:13

Re: FileZilla won't use my system default date format

#8 Post by toastpod » 2016-03-04 14:20

It would appear that they are already set correctly, as below. Have you changed your own date format in Windows to dd/mm/yy (United Kingdom)? What is the result?
Attachments
date.png
date.png (19.15 KiB) Viewed 3166 times

User avatar
boco
Contributor
Posts: 25241
Joined: 2006-05-01 03:28
Location: Germany

Re: FileZilla won't use my system default date format

#9 Post by boco » 2016-03-04 18:57

With Region set to UK and using System defaults for date, creating a new directory shows its timestamp as

Code: Select all

04/03/2016 19:55:49
Does that look correct? Note: I use Windows 7.


In FileZilla Settings, Interface - Date/Time format, it's possible to force the date to be UK with the Custom string

Code: Select all

%d/%m/%Y
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
FileZilla connection test: https://filezilla-project.org/conntest.php
### END SIGNATURE BLOCK ###

toastpod
500 Command not understood
Posts: 4
Joined: 2016-03-03 17:13

Re: FileZilla won't use my system default date format

#10 Post by toastpod » 2016-03-04 21:24

boco wrote:With Region set to UK and using System defaults for date, creating a new directory shows its timestamp as

Code: Select all

04/03/2016 19:55:49
Does that look correct?
Thanks. Yes it does.
boco wrote:Note: I use Windows 7.
I use Windows 10 64-bit, maybe the issue is related to Windows 10, perhaps someone else can test?
boco wrote:In FileZilla Settings, Interface - Date/Time format, it's possible to force the date to be UK with the Custom string

Code: Select all

%d/%m/%Y
Thanks, that's what I do, and I'm glad that setting is there! But ideally this bug would be fixed so that "Use system defaults" works correctly.

Post Reply