Time Stamp

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Rbarwig
500 Command not understood
Posts: 3
Joined: 2018-12-13 20:03
First name: Rick
Last name: Barwig

Time Stamp

#1 Post by Rbarwig » 2018-12-13 20:10

Hi,
I am using the client version 3.39.0 connecting to a Windows Server running Bullet proof FTP server. I just created a text file on my desktop at 13:01, I uploaded it to the FTP server and the timestamp shows the file modification time of 08:00. I checked to make sure my offset is set to 0, both the server and I are in the central time zone. Both the server and my desktop have the correct time and time zone.

What would cause the time stamp to be incorrect?

User avatar
boco
Contributor
Posts: 24535
Joined: 2006-05-01 03:28
Location: Germany

Re: Time Stamp

#2 Post by boco » 2018-12-14 00:00

1. Do you upload via the FTP protocol?
2. If yes, does the server software support the MFMT command?
3. Did you enable the option "Preserve timestamps of transferred files" (in menu Transfer)?
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

User avatar
botg
Site Admin
Posts: 32200
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Time Stamp

#3 Post by botg » 2018-12-14 08:19

Is the server system by chance located in UTC-8? if so, this issue can happen if the server does not adhere to the FTP specifications and sends timestamps in local time instead of using UTC±0.

Rbarwig
500 Command not understood
Posts: 3
Joined: 2018-12-13 20:03
First name: Rick
Last name: Barwig

Re: Time Stamp

#4 Post by Rbarwig » 2018-12-18 17:41

boco wrote:
2018-12-14 00:00
1. Do you upload via the FTP protocol?
2. If yes, does the server software support the MFMT command?
3. Did you enable the option "Preserve timestamps of transferred files" (in menu Transfer)?
I did not have the preserve option set. I do now. Thank you!

Rbarwig
500 Command not understood
Posts: 3
Joined: 2018-12-13 20:03
First name: Rick
Last name: Barwig

Re: Time Stamp

#5 Post by Rbarwig » 2018-12-18 17:42

botg wrote:
2018-12-14 08:19
Is the server system by chance located in UTC-8? if so, this issue can happen if the server does not adhere to the FTP specifications and sends timestamps in local time instead of using UTC±0.
My server is not set to UTC, but the other response to my post resolved the issue. I did not have the preserve time stamp enabled under the transfer menu.

Post Reply