FTP over TLS stopped working (Bug in Client)

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
steels
500 Command not understood
Posts: 2
Joined: 2019-02-04 11:51

FTP over TLS stopped working (Bug in Client)

#1 Post by steels » 2019-02-04 12:01

Hi everyone,

since last week I am unable to use explicit FTP over TLS. As far as I am aware, it had been working without a problem before that. The insecure FTP connection still works, but as it is a potential security risk, I would rather want to get the encrypted connection going again.

I have reached out to my hosting provider, who told me that the fault seems to be a bug in FileZilla (?). Does anyone know, if this is being worked on?

This is the FTP Log output from FileZilla:

Code: Select all

Status:	Resolving address of example.url
Status:	Connecting to 123.123.123.123:21...
Status:	Connection established, waiting for welcome message...
Status:	Initializing TLS...
Status:	Verifying certificate...
Status:	TLS connection established.
Status:	Server does not support non-ASCII characters.
Status:	Logged in
Status:	Retrieving directory listing of "/www"...
Command:	CWD /www
Response:	250 CWD command successful
Command:	PWD
Response:	257 "/www" is the current directory
Command:	TYPE I
Response:	200 Type set to I
Command:	PASV
Response:	227 Entering Passive Mode (213,145,225,20,195,145).
Command:	LIST
Response:	150 Opening BINARY mode data connection for file list
Response:	425 Unable to build data connection: Operation not permitted
Error:	Failed to retrieve directory listing
Status:	Disconnected from server
Big thanks in advance for your help! :)
Last edited by steels on 2019-02-04 16:38, edited 1 time in total.

User avatar
botg
Site Admin
Posts: 31976
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FTP over TLS stopped working

#2 Post by botg » 2019-02-04 12:04

That's a known bug in ProFTPd, the FTP server software running on the server machine. ProFTPd, while advertising support for TLS 1.3, does not implement it correctly. Please contact your server administrator or server hosting provider so that they in turn can contact ProFTPd support to have the server fixed.

steels
500 Command not understood
Posts: 2
Joined: 2019-02-04 11:51

Re: FTP over TLS stopped working

#3 Post by steels » 2019-02-04 12:39

botg wrote:
2019-02-04 12:04
That's a known bug in ProFTPd, the FTP server software running on the server machine. ProFTPd, while advertising support for TLS 1.3, does not implement it correctly. Please contact your server administrator or server hosting provider so that they in turn can contact ProFTPd support to have the server fixed.
I don't think that the problem lies with the server. I have tried connecting with WinSCP and it works without a problem. (FTP connection over TLS)
That's a good sign that the problem is with the FileZilla Client.

drgw
500 Command not understood
Posts: 1
Joined: 2019-02-04 15:37

Re: FTP over TLS stopped working (Bug in Client)

#4 Post by drgw » 2019-02-04 17:31

Hello!
Today I made the same experience: Suddenly Filezilla doesn't open Server connection. First he accepts the login data, the certificate comes, and when I click for going further, the connection breaks because of timeout:

Code: Select all

Status:      	Auflösen der IP-Adresse für example.ch
Status:      	Verbinde mit 83.xx.xx.xx:21...
Status:      	Verbindung hergestellt, warte auf Willkommensnachricht...
Status:      	Initialisiere TLS...
Status:      	Überprüfe Zertifikat...
Status:      	TLS-Verbindung hergestellt.
Status:      	Angemeldet
Status:      	Empfange Verzeichnisinhalt...
Befehl:      	PWD
Antwort:    	257 "/" is the current directory
Befehl:      	TYPE I
Antwort:    	200 Type set to I
Befehl:      	PASV
Antwort:    	227 Entering Passive Mode (83,xx,xx,xx,142,28).
Befehl:      	MLSD
Fehler:      	Zeitüberschreitung der Verbindung nach 20 Sekunden Inaktivität
Fehler:      	Verzeichnisinhalt konnte nicht empfangen werden
Status:      	Verbindung zum Server getrennt
Maybe you find something to solve this problem? Thanks a lot in advance.

User avatar
botg
Site Admin
Posts: 31976
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: FTP over TLS stopped working (Bug in Client)

#5 Post by botg » 2019-02-05 09:46

I don't think that the problem lies with the server.
Why not?
I have tried connecting with WinSCP and it works without a problem. (FTP connection over TLS)
WinSCP is outdated, it does not even make use of TLS 1.3. Try using any different modern client that uses TLS 1.3

Post Reply