Strange performance issue with FileZilla lagging/freezing/slow performance.

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
Squirtles
500 Command not understood
Posts: 5
Joined: 2019-12-21 22:58

Strange performance issue with FileZilla lagging/freezing/slow performance.

#1 Post by Squirtles » 2019-12-22 00:42

Hi.
I've done a fresh install of Windows 10 and I was transferring some big files from a Linux (fedora 31) PC to the Windows PC via SFTP.

During these transfers the filezilla client froze several times, completley locked up the PC for 10-20 seconds (no mouse movement), slow transfer speeds (1 file transferring on its own did 40-50MB/s if that).

So I've been fiddling about, using the PC normally and...the issue seemed to have cleared up...until I reboot the windows PC and have nothing running and the issue then returns.

I open several programmes and...the issue goes. So I've closed them one by one and the issue disappears when Skype (Windows version, not UWP/Windows store version) is open! Now transfers go at 110MB/s lag free.

Close skype and filezilla, open filezilla on its own and the issue is back.

I've noticed when Skype is open, one core (or logical processor) has 60-80% usage, another 40-50% usage and the rest minimal.

When Skype is closed, 1-2 cores are pinned at 100% and System Interrupts process runs at 9-10%.

I'm completely baffled by this and why Skype being open would suddenly make everything run normally.

Also, it only seems to be an issue with high speed transfers.

Also some extra messing around with figuring out how to trigger it working normally.
Flash videos in a browser make it run normally.
I loaded up a YouTube video in Chrome (HTML5). When the video was playing, FileZilla ran normally. When I paused the video, closed and reopened FileZilla, the lagging issue came back.

Any ideas at all what's causing this or how to fix it? Besides running Skype all the time I mean...
It really is the weirdest thing I've come across.

Thanks for any help you can provide.

User avatar
boco
Contributor
Posts: 24910
Joined: 2006-05-01 03:28
Location: Germany

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#2 Post by boco » 2019-12-22 00:48

Are you on an AMD Ryzen or similar processer, with a pre-1903 Windows 10 version, by chance? Ryzens had performance issues, until MS introduced a new core scheduler in 1903 that works much better.

When Skype is open, it seems to keep the cores alive, idle cores are usually put to sleep.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Squirtles
500 Command not understood
Posts: 5
Joined: 2019-12-21 22:58

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#3 Post by Squirtles » 2019-12-22 00:50

Hi thanks for the speedy reply.

Unfortunately no, it's a fresh install of 1909 on an Intel X99 platform.

Thanks

*Edit* I think I forgot to mention this is all over LAN.
And I've deleted the folders from appdata\roaming to start fresh and see if it was anything I'd configured but it's the same.

User avatar
boco
Contributor
Posts: 24910
Joined: 2006-05-01 03:28
Location: Germany

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#4 Post by boco » 2019-12-22 01:01

Some users also had problems with the power throttling feature MS introduced in 1709. Power throttling is enabled for Intel Skylake and higher.

You might, as a test, disable power throttling temporary and check if performance increases. Refer to the following page (or simply search online for Windows 10 CPU power throttling):

Code: Select all

https://winaero.com/blog/disable-power-throttling-windows-10-1709/
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

Squirtles
500 Command not understood
Posts: 5
Joined: 2019-12-21 22:58

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#5 Post by Squirtles » 2019-12-22 01:26

Thanks again for the reply.

I've tried that setting and no joy.
If it was introduced in Skylake or higher though it was a long shot as I'm running Haswell-E.

Also I've installed vsftpd on the linux machine (sorry, no filezilla server for linux!) and...it works normally. Not going to keep that on though as I don't really want to run an FTP server on it. sftp should run fine...

Thanks

Squirtles
500 Command not understood
Posts: 5
Joined: 2019-12-21 22:58

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#6 Post by Squirtles » 2019-12-22 08:15

OK yeah I've found the cause.
"Intrusion Prevention" functionality in my antivirus programme is doing it.

The very old advice of "try turning your antivirus off" rings true...

Although I still don't understand how having skype open or flash/youtube/spotify playing would make it work normally...and why it doesn't affect normal FTP.

User avatar
botg
Site Admin
Posts: 32600
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#7 Post by botg » 2019-12-22 14:39

They might disable this insanely slow and resource consuming, and ultimately pointless "intrusion Prevention" if they detect the user is doing something that requires speedy processing, such as audio/video streaming.

Squirtles
500 Command not understood
Posts: 5
Joined: 2019-12-21 22:58

Re: Strange performance issue with FileZilla lagging/freezing/slow performance.

#8 Post by Squirtles » 2019-12-22 15:32

I agree.
It was just...very strange trying to find what was causing it since it worked normally when skype/flash/spotify/html5 youtube was playing. that really threw me off...and makes little to no sense.

Also the fact that regular ftp worked normally and the issue was confined to sftp. Transferring files between SSDs worked normally too...so I'm still scratching my head trying to figure it out.

Post Reply