Specifying external IP for passive mode makes the ftp server work wrong.

Need help with FileZilla Server? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
andyb
500 Command not understood
Posts: 2
Joined: 2019-04-06 15:49

Specifying external IP for passive mode makes the ftp server work wrong.

#1 Post by andyb » 2019-04-06 16:03

I have rent a VPS Server and installed Windows 2019 Server and FileZilla FTP Server 0.9.60 on it.
The puplic IP address is for ex. 95.95.95.95 and the internal IP is for ex. 10.10.10.10.
In the VPS config the external IP 95.95.95.95 is routed to the internal IP 10.10.10.10.

I configured passive ports 50000-50100 in FileZilla and opened this ports in Windows Firewall and the VPS Firewall config.
And i entered the external IP 95.95.95.95 in "Passive mode settings" / "Use the following IP".

When i connect to the server i get for ex.
227 Entering Passive Mode (95,95,95,95,195,86)
disconnected
on the server. The FTP client displays: Disconnected from server: ECONNABORTED - Connection aborted

When i change the setting to Default (specify no externeal IP) then it seems to work. I get for ex. this on the server:
227 Entering Passive Mode (10,10,10,10,195,86)
STOR Test.txt
150 Opening data channel for file upload to server of "/Test.txt"
226 Successfully transferred "/Test.txt"
The client displays:
227 Entering Passive Mode (95,95,95,95,195,86)

It seems to work without external IP specified for some reason idk, but i wonder whether the FTP Server really sends the correct info
"95,95,95,95,195,86" to the client or whether the client just changes "10,10,10,10,195,86" to "95,95,95,95,195,86".

I want to specify the external IP in the FTP Server settings as suggested when behind NAT but this does not work for me.
The server then seems to try to listen on external IP 95.95.95.95 which fails.
It makes no difference whether "Don't use external IP for local connections" is checked or not.
The server should listen on the internal IP 10.10.10.10 anyway and just tell the client to connect to external IP 95.95.95.95.
Maybe i don't understand something or missed something to configure. Any advice?

User avatar
boco
Contributor
Posts: 24549
Joined: 2006-05-01 03:28
Location: Germany

Re: Specifying external IP for passive mode makes the ftp server work wrong.

#2 Post by boco » 2019-04-06 18:53

Please read the chapter about malicious firewalls and routers in our Network Configuration guide.
### BEGIN SIGNATURE BLOCK ###
No support requests per PM! You will NOT get any reply!!!
FTP connection problems? Do yourself a favor and read Network Configuration.
All FileZilla products fully support IPv6. http://worldipv6launch.org
### END SIGNATURE BLOCK ###

andyb
500 Command not understood
Posts: 2
Joined: 2019-04-06 15:49

Re: Specifying external IP for passive mode makes the ftp server work wrong.

#3 Post by andyb » 2019-04-06 21:03

Thank you for the hint!
I activated TLS and now the FTP client log says this:

Response: 227 Entering Passive Mode (10,10,10,10,195,86)
Status: Server sent passive reply with unroutable address. Using server address instead.

A test file upload worked.
With TLS enabled the NAT no longer can "fix" the address.
With TLS enabled it also works now when i enter the external IP.
So, i think now FileZilla works fine. The NAT messes up things in non TLS mode.

Post Reply