Unable to connect to server - no password sent/pwd popup not seen

Need help with FileZilla Client? Something does not work as expected? In this forum you may find an answer.

Moderator: Project members

Post Reply
Message
Author
gochiefs2
500 Command not understood
Posts: 3
Joined: 2019-09-10 21:31
First name: N
Last name: C

Unable to connect to server - no password sent/pwd popup not seen

#1 Post by gochiefs2 » 2019-09-10 21:37

All,

Thanks in advance! FileZilla is pretty sweet but I've been banging my head against the wall for a couple hours here and would love some input.

The first time I set up a connection with a client server via SFTP (key AND pwd required) I eventually got it working - we'd connect, the key exchange would work, I'd get a prompt to enter my password and boom I was connected. I was able to upload a couple test files and they confirmed receipt.

Settings:
Protocol: SFTP
Logon Type: Key File

NOW, I see the key exchange working but I keep getting failures. Looking at the debug logs it appears that it sends a blank password due to keyboard-interaction failing, but I never see the popup asking me for the password. Any thoughts?

The log snippet:
14:29:08 Trace: Offer of public key accepted, trying to authenticate using it.
14:29:08 Trace: Further authentication required
14:29:08 Trace: Attempting keyboard-interactive authentication
14:29:08 Trace: Using keyboard-interactive authentication. inst_len: 29, num_prompts: 1
14:29:08 Command: Pass:
14:29:09 Trace: Keyboard-interactive authentication failed
14:29:09 Trace: Attempting keyboard-interactive authentication
14:29:09 Trace: Using keyboard-interactive authentication. inst_len: 29, num_prompts: 1
14:29:09 Error: Authentication failed.
14:29:09 Trace: CControlSocket::DoClose(1030)
14:29:09 Trace: CControlSocket::ResetOperation(1094)
14:29:09 Trace: CSftpConnectOpData::Reset(1094) in state 3
14:29:09 Error: Critical error: Could not connect to server
14:29:09 Trace: CFileZillaEnginePrivate::ResetOperation(1094)

Thanks!

User avatar
botg
Site Admin
Posts: 32331
Joined: 2004-02-23 20:49
First name: Tim
Last name: Kosse
Contact:

Re: Unable to connect to server - no password sent/pwd popup not seen

#2 Post by botg » 2019-09-11 07:25

Configure the key in the settings dialog and use normal login type in the Site Manager.

gochiefs2
500 Command not understood
Posts: 3
Joined: 2019-09-10 21:31
First name: N
Last name: C

Re: Unable to connect to server - no password sent/pwd popup not seen

#3 Post by gochiefs2 » 2019-09-11 17:40

@botg thank you very much, I'll try that out!

gochiefs2
500 Command not understood
Posts: 3
Joined: 2019-09-10 21:31
First name: N
Last name: C

Re: Unable to connect to server - no password sent/pwd popup not seen

#4 Post by gochiefs2 » 2019-09-11 17:52

That worked, thank you very much! Really appreciate the steer.

Post Reply